Cannot install jellyfin

Here is the error I am getting http://prntscr.com/q45b1c

First install I ever did worked, but after I tried to downgrade to a previous version (because DLNA didn’t work properly), I now can’t install anymore. I did a systemwide seach for jellyfin and deleted everything, deleted a bunch of registry values and deleted the jellyfin service. There was no uninstall option. So then when I try to install it no longer says that I already have a jellyfin server (due to the manual removal), and tries to install. But then I get the error above. Trying to install the newest version, 10.4.2 x64

Are you really sure you want to install the service method and not the basic method?

It’s fine if you do, I just want to understand the reasoning why. The basic method is designed to match what Emby and Plex do, which is run with a tray icon.

Anyway, you said you deleted the service from the Windows Services list (services.msc)?

1 Like

It doesn’t give me an option to install the basic one. It just says existing installation of jellyfin server detected, and wants to “upgrade” it. I just removed all jellyfin files windows could find and deleted the jellyfin service (SC REMOVE JellyfinService) but still it’s finding some file. Also restarted and downloaded new exe.

@Zipur There’s a few things it does to try and “detect” that you have an existing installation.

If you have an uninstall option now though, in Programs & Features, I’d try that first. If that doesn’t appear, check for an uninstall at “C:\Program Files\Jellyfin\Server\Uninstall.exe”.

If that doesn’t exist either, do this:

  • remove the service if it exists
  • Delete the registry entry “HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432node\Jellyfin” (don’t just delete the values, the actual entries themselves must be removed)

I’m thinking that if you only deleted the values of the registry keys, but left the entries actually there, it would have detected it as an install still.

1 Like

Hey, that worked and I was able to install jellyfin basic again. But my root problem still stands; I can’t get the app to connect. I used my default gateway with “:8096” but it did not connect.

On Windows, there’s a tray app that you can launch to start Jellyfin. There should be a shortcut on your desktop, as well as in the Start Menu. When you run the tray app, you can right click it and choose “Start Jellyfin” and “Open Jellyfin” as needed. This should bring up the page for you.

You use your default gateway? Is that the IP listed as default gateway when you run ipconfig? As that’s your router and not your PC, you need to use either 127.0.0.1 (localhost) or the address listed under IPv4 address when you run ipconfig

1 Like

I’ve fixed the issue, you can see it here: https://www.reddit.com/r/jellyfin/comments/e8zlk9/still_cannot_connect_to_server_with_app/