Cannot Login After Update to 10.5.5-1

Hi Folks,

I installed Jellyfin as an LXC from Turnkey in Proxmox a few months ago. Everything has been working fine. Today, I ran a package update on the container. Jellyfin is now running on 10.5.5-1. But, I am unable to login. I have tried restarting the Jellyfin service, I’ve tried restarting the container (recommendation from searching for solution), no difference. Beyond that, I have not had much luck in understanding what I need to do or how to resolve the problem.

When trying to log in, I get a very generic “Connection Failure - We’re unable to connect to the selected server right now. Please ensure it is running and try again.”.

It is just served locally. Access had been just fine until today when I did the update.

Here’s what I get in my log:

*[2020-06-13 21:10:34.795 +00:00] [ERR] Error processing request. URL: "http://10.0.1.42:8096/Users/authenticatebyname"*
*System.ArgumentException: String doesn't contain enough segments (Parameter 'hashString')*
*   at MediaBrowser.Common.Cryptography.PasswordHash.Parse(String hashString)*
*   at Emby.Server.Implementations.Library.DefaultAuthenticationProvider.Authenticate(String username, String password, User resolvedUser)*
*   at Emby.Server.Implementations.Library.UserManager.AuthenticateWithProvider(IAuthenticationProvider provider, String username, String password, User resolvedUser)*
*   at Emby.Server.Implementations.Library.UserManager.AuthenticateLocalUser(String username, String password, String hashedPassword, User user, String remoteEndPoint)*
*   at Emby.Server.Implementations.Library.UserManager.AuthenticateUser(String username, String password, String hashedPassword, String remoteEndPoint, Boolean isUserSession)*
*   at Emby.Server.Implementations.Session.SessionManager.AuthenticateNewSessionInternal(AuthenticationRequest request, Boolean enforcePassword)*
*   at MediaBrowser.Api.UserService.Post(AuthenticateUserByName request)*
*   at Emby.Server.Implementations.Services.ServiceExecGeneral.GetTaskResult(Task task)*
*   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost httpHost, IRequest httpReq, HttpResponse httpRes, ILogger logger, CancellationToken cancellationToken)*
*   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IHttpRequest httpReq, String urlString, String host, String localPath, CancellationToken cancellationToken)*

Do you recall what version you were on before?

Basically, there was a change in password authentication somewhere in the 10.3 to 10.4 transition I believe (I could find it, but it’s not important). If you didn’t go through that version set and made a big jump, the migration was removed and it would probably cause an issue like this.

The fix is to reset your password. The generic error message “Connection Failure” in this case means that the password couldn’t be checked, and we’ve fixed that message in future.