Can't add server in jellyfin android app

I installed jellyfin on my desktop (linux Mint). No problems. I then installed the app on my tablet, but I can’t add my local server. I’ve tried every address combination - http(s)://local server, IP address, IP address preceded by http(s), etc etc. All I get is “can’t connect to server” message.

The app works, as I was able to connect to my son’s server in another country. Even he can’t fix the problem.

So, can anybody help me, please?

Can you connect to the server via the IP in a browser on the tablet?

Are you adding the port to the end?

As below?

http://192.168.1.234:8096

I replied to you both, but the forum won’t accept the replies, so here they are.

@TrueTechy: Yes, if I enter 192.168.0.2:8096/, I get to the jellyfin log-in page.
@ChiefMedicalOfficer: On the add server page, yesterday, there was a second box for port, prefilled with 8096.I tried your address both with and without the port at the end - same result, error. Today, the jellyfin app has been updated - the add a server page no longer has the second (port) box. So I tried again - same result.

Thanks for the help - it’s appreciated

Well, all of a sudden, it worked. I don’t know why, but I don’t care.

Thanks