IE 11 - Black Screen on WebUI

Having a really weird issue.

I’ve had Jellyfin up and running for a couple of weeks now. Haven’t really been a heavy user of it, mostly have been using my mobile client to connect and stream audio to Google Home devices.

However, I am 100% sure that the last time I logged into the web interface everything was fine.
I am running using nginx reverse proxy and am setup with the recommended config for that.

Today, when I went to access the webui from my laptop using the https external address, all I got was a black UI with absolutely nothing else on it.

I tried to access it from both Chrome and IE and had the same issue.

I was however able to access on the local port without the reverse proxy.
So, first thing I did was restart nginx, and then restart my router (which runs nginx).
Neither of these fixed the issue.

It is worth noting here that I have half a dozen other web apps running through nginx this way and all the others were working fine.

I tinkered with a few setting, all of which I reverted back to what they were originally at.
I then tried to access from my mobile app, which worked fine and also from the browser (Chrome) on my phone, which also worked.

I then came back to my laptop and after refreshing (which I had already done multiple times), I was able to get Chrome to load properly.

In short, nothing changed. Any parameters I changed, I changed back. Issue did not work after a reboot of nginx alone, and there is no clear indicator of what caused the issue (since there were 0 changes, or why it started to work again).

However, IE continue to not work.
Edge does.
Chrome does.
I have cleared cache and totally reset IE settings

While I don’t really care about not being able to use IE, I’m concerned at the fact that I lost access like this to all my browsers and since the effect was the same, and I’m still having the issue in IE, perhaps there is some common link. ?

I’ll be honest - I’m surprised if it ever loaded in IE at all. What version of Jellyfin are you running?

Latest…10.3.7.

I’m not claiming that it ever did run in IE, honestly I’m not sure I had tested.
I am referencing it directly though because the behavior I am seeing in IE is the behavior I was seeing in Chrome as well this morning until I started toggling and restarting stuff.

As mentioned, anything I changed I reverted back to how I had it before, so I’m not sure why chrome was acting up. I found these issues:


Which kind of describe what I was seeing, however they don’t have a lot of info attached to them.
The one makes reference that the nginx setup might be incorrect, but I don’t think that is relevant in my case because:
a) I already am using the proper referenced config
b) Mine was working fine previously and then with no changes it stopped working and then started working again after fidgeting (but reverting back) to certain settings.

Unfortunately I wanted to just get it working so I played around instead of posting first so I can’t recreate the issue now, but seemingly you guys have had issues with this in the past and there possibly might still be some based on my recent experience.

Let me know if you have any ideas or if I can provide any more data points.