Install Errors for Linux Mint

Newbie to Linux so a bit green we all need to learn somewhere.

Installed Linux Mint tried installing from stable Version

sudo apt install apt-transport-https
wget -O - https://repo.jellyfin.org/jellyfin_team.gpg.key | sudo apt-key add -
echo "deb [arch=$( dpkg --print-architecture )] https://repo.jellyfin.org/$( awk -F'=' '/^ID=/{ print $NF }' /etc/os-release ) $( awk -F'=' '/^VERSION_CODENAME=/{ print $NF }' /etc/os-release ) main" | sudo tee /etc/apt/sources.list.d/jellyfin.list
sudo apt update
sudo apt install jellyfin

get errors saying cant find

E: Failed to fetch https://repo.jellyfin.org/linuxmint/dists/ulyana/InRelease  Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
E: The repository 'https://repo.jellyfin.org/linuxmint ulyana InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

any help highly helpful.

We don’t specifically package Jellyfin for Linux Mint, but since it’s based on Ubuntu, you can use that version with just a few tweaks.

Here’s what you’ll want to do:

  1. In the terminal, type sudo nano /etc/apt/sources.list.d/jellyfin.list

  2. Find the part that says linuxmint and change it to ubuntu.

  3. Find the part that says ulyana and change it to focal .

  4. Press Ctrl+X to exit, and press Y to save. Press Enter to accept the file name.

Then you can try the update and install commands again:

sudo apt update
sudo apt install jellyfin-server
1 Like

I got to the part where you hit Ctrl+X to exit and press Y to save but then it goes to a spot that I can only cancel and try again. I tried it several times to save but it wasn’t letting me. I included a snapshot so you can see what I’m talking about. I’m very new to Linux myself. Thanks in advance for any help.

Oops. Sorry.
After Ctrl+X, and then Y, press Enter on that screen you see. That will save the file for you :slight_smile:

Wow. Something so easy. All I had to do was hit “enter.” Don’t I feel dumb! Thanks for your quick response.

The key sequence for saving the file in nano is dependant on the version of nano. I’m on version 2.9.3,
to write the file to disk is CTRL+O, CTRL+X exits nano.

1 Like