Jellyfin_10.5.2.portable.tar.gz file not found jellyfin-web\componentscastSenderApi.js

The directions for running the portable version were not clear. i finally got it running, but I didn’t see instructions on configuring or adding content on the Getting Started page.

Once I started Jellyfin, my browser opens, a black page displays and an error is displayed in the command prompt window.

That’s it. If i refresh the blank page, the same error message is dispalyed in the command window. I looked for the file manually and didn’t find it.

i tried shutting Jellyfin down, removing it and re-extracting the archive. I had the same results when ran.

I am running Win7 x64 using Chrome Version 80.0.3987.149 (Official Build) (64-bit)

I was running this on a Lenovo Y50-70 laptop with a Samsung 4k LCD.

The command prompt output, including one browser refresh (I have no idea how the Sony reference crept in. I have one, it is not turned on and BT doesn’t work on this PC.);

C:\jellyfin_10.5.2>dotnet jellyfin.dll
[19:33:44] [INF] [1] Main: Jellyfin version: 10.5.2
[19:33:44] [INF] [1] Main: Arguments: ["C:\\jellyfin_10.5.2\\jellyfin.dll"]
[19:33:44] [INF] [1] Main: Operating system: Windows
[19:33:44] [INF] [1] Main: Architecture: X64
[19:33:44] [INF] [1] Main: 64-Bit Process: True
[19:33:44] [INF] [1] Main: User Interactive: True
[19:33:44] [INF] [1] Main: Processor count: 8
[19:33:44] [INF] [1] Main: Program data path: C:\Users\marks\AppData\Local\jelly
fin
[19:33:44] [INF] [1] Main: Web resources path: C:\jellyfin_10.5.2\jellyfin-web
[19:33:44] [INF] [1] Main: Application directory: C:\jellyfin_10.5.2\
[19:33:44] [INF] [1] ServerConfigurationManager: Setting cache path: C:\Users\ma
rks\AppData\Local\jellyfin\cache
[19:33:44] [INF] [1] App: Loading assemblies
[19:33:44] [INF] [1] Main: Kestrel listening on all interfaces
[19:33:45] [INF] [1] App: Running startup tasks
[19:33:45] [INF] [1] TaskManager: Daily trigger for Extract Chapter Images set t
o fire at 03/30/2020 02:00, which is 6:26:14.9171345 from now.
[19:33:45] [INF] [1] MediaBrowser.MediaEncoding.Encoder.MediaEncoder: FFmpeg: No
tFound:
[19:33:45] [INF] [1] App: ServerId: 63efe5f778774638b2bb68a4cff1a9ef
[19:33:45] [INF] [1] App: Executed all pre-startup entry points in 0:00:00.23349
35
[19:33:45] [INF] [1] App: Core startup complete
[19:33:45] [INF] [16] Dlna: Registering publisher for urn:schemas-upnp-org:devic
e:MediaServer:1 on 192.168.1.85
[19:33:45] [INF] [1] App: Executed all post-startup entry points in 0:00:00.3399
247
[19:33:45] [INF] [1] Main: Startup complete 0:00:01.8252913
[19:33:46] [ERR] [15] Emby.Server.Implementations.HttpServer.HttpListenerHost: E
rror processing request: Could not find file 'C:\jellyfin_10.5.2\jellyfin-web\co
mponentscastSenderApi.js'.
[19:33:48] [INF] [14] TaskManager: StartupTrigger fired for task: Update Plugins

[19:33:48] [INF] [14] TaskManager: Queueing task PluginUpdateTask
[19:33:48] [INF] [9] TaskManager: Executing Update Plugins
[19:33:48] [INF] [14] TaskManager: Update Plugins Completed after 0 minute(s) an
d 0 seconds
[19:33:48] [INF] [14] TaskManager: ExecuteQueuedTasks
[19:33:51] [INF] [17] Dlna: No matching device profile found. The default will n
eed to be used.
DeviceDescription:
FriendlyName:HT-Z9F
Manufacturer:Sony Corporation
ManufacturerUrl:http://www.sony.net/
ModelDescription:
ModelName:HT-Z9F
ModelNumber:BAR-2018
ModelUrl:
SerialNumber:

[19:33:51] [INF] [17] Dlna: DLNA Session created for HT-Z9F - HT-Z9F
[19:34:28] [ERR] [13] Emby.Server.Implementations.HttpServer.HttpListenerHost: E
rror processing request: Could not find file 'C:\jellyfin_10.5.2\jellyfin-web\co
mponentscastSenderApi.js'.
[19:34:34] [ERR] [15] Emby.Server.Implementations.HttpServer.HttpListenerHost: E
rror processing request: Could not find file 'C:\jellyfin_10.5.2\jellyfin-web\co
mponentscastSenderApi.js'.

Regards.

If you’re using Windows, you should use the .exe installer if you can. It’ll be a lot more robust right now, and easier to get going.
This error is because of a web build issue that we had, it’s been fixed in most places but not all. It’ll be fixed for sure with the next update.

It found the TV on your network. Even if they’re not on, a lot of Smart TVs and Receivers will advertise themselves as being available for playback. In this case, your sound bar seems to be letting Jellyfin know that it can playback audio.

Thanks for your quick reply. I am trying to not install new software on the laptop while I try and find out what is causing problems for other programs.

I also looked for a Vbox machine and didn’t find one. I used to run Debian Plex in vbox with an SMB share connected to a shared USB drive on the host. This was on a Win7 laptop. This ran well when only occasional buffering. Will work for Jellyfin ?

I currently use Plex on an ARM based QNAP NAS. Jellyfin is not available. What would it take to get Jellyfin working on this?

Regards.

We don’t provide any VM images, so there would be no vbox for example. You could use Docker but that can get a bit messy on Windows (hence why I suggest the direct install).

We don’t pack natively for QNAP, but there is a person out there who does. I think they charge a small fee to cover their time making the package. I forget where it is though. I think there’s a bug with ARM at the moment that we’re solving though.