Nextcloudpi with jellyfin

Hi, I’m trying to build a server with raspberry pi 4. I installed nextcloudpi and everything is working fine, the idea is that I install jellyfin along and give jellyfin permission for the music folder and use it as a media streaming center. I installed jellyfin and sudo service status jellyfin shows that its running. But I can’t access to local:8096 on my browser. I appreciate any help. Thanks.

It should be http://localhost:8096 vor http://127.0.0.1:8096 when you’re trying to connect from the pi itself. It is http://{ip-address of the pi}:8096 from other devices in your network.

If this des not work either, check if jellyfin is running in console. “Service jellyfin status” or “ps aux|grep jellyfin”

I cant connect to it thorugh the browser. Here is the ‘service jellyfin status’ output:

I did systemctl daemon-reload and the warning disappears but i still cant connect…

What dies “netstat -tulpen” show? (Apt install net-tools on debian-like distribution) There should be at least one Entry for jellyfin, with something like :::8096 or ...:8096 (ipv6 and/or ipv4) and if there’s a different port number for 8096, try that one in the Browser.

Here is the output of netstat -tulpen :

I tried them all to no avail… :frowning:

Looking at that systemctl output, it doesn’t look like Jellyfin is properly running at all. What happens if you restart it?

systemctl restart jellyfin.service

Here is the output mate:

I did not spot that jellyfin was not correctly running in the first screen, sorry. I’d guess from your last screen, that it’s still not running. Does “journalctl -xe” show anything relevant? Preferably run this directly after “systemctl restart jellyfin.service”

Mine looks like this:
"

Hello,
does jellyfin create a log file, when it’s started? run
“more /var/log/jellyfin/jellyfin_001.log” to see it. (or less, tail, cat, whatever floats your boat or is available) Be aware that 001 is a number that’s incremented by log-rotation, so it might be a higher number, autocomplete the existing filenames with {tab}{tab}, once you’re in /var/log/jellyfin/
If you think the log is something we should see, post it here, blanking out any sensitive information.

I did a bit of reading up on nextcloudpi and testing with my spare pi, but from what I can tell, nextcloudpi seems rather different than an old school linux, as it uses docker or snappy, so I’m interested in how you installed jellyfin? Directly from deb-packages, have you added the sources.list and run apt install jellyfin or is there some kind of docker-image or snappy-package you started? Depending on this, all directories mentioned may be different, or even inside some kind of image, container or package.

Best regards,
Benchlor