Nextcloudpi with jellyfin

Hi, I’m trying to build a server with raspberry pi 4. I installed nextcloudpi and everything is working fine, the idea is that I install jellyfin along and give jellyfin permission for the music folder and use it as a media streaming center. I installed jellyfin and sudo service status jellyfin shows that its running. But I can’t access to local:8096 on my browser. I appreciate any help. Thanks.

It should be http://localhost:8096 vor http://127.0.0.1:8096 when you’re trying to connect from the pi itself. It is http://{ip-address of the pi}:8096 from other devices in your network.

If this des not work either, check if jellyfin is running in console. “Service jellyfin status” or “ps aux|grep jellyfin”

I cant connect to it thorugh the browser. Here is the ‘service jellyfin status’ output:

I did systemctl daemon-reload and the warning disappears but i still cant connect…

What dies “netstat -tulpen” show? (Apt install net-tools on debian-like distribution) There should be at least one Entry for jellyfin, with something like :::8096 or ...:8096 (ipv6 and/or ipv4) and if there’s a different port number for 8096, try that one in the Browser.

Here is the output of netstat -tulpen :

I tried them all to no avail… :frowning:

Looking at that systemctl output, it doesn’t look like Jellyfin is properly running at all. What happens if you restart it?

systemctl restart jellyfin.service

Here is the output mate:

I did not spot that jellyfin was not correctly running in the first screen, sorry. I’d guess from your last screen, that it’s still not running. Does “journalctl -xe” show anything relevant? Preferably run this directly after “systemctl restart jellyfin.service”

Mine looks like this:
"

Hello,
does jellyfin create a log file, when it’s started? run
“more /var/log/jellyfin/jellyfin_001.log” to see it. (or less, tail, cat, whatever floats your boat or is available) Be aware that 001 is a number that’s incremented by log-rotation, so it might be a higher number, autocomplete the existing filenames with {tab}{tab}, once you’re in /var/log/jellyfin/
If you think the log is something we should see, post it here, blanking out any sensitive information.

I did a bit of reading up on nextcloudpi and testing with my spare pi, but from what I can tell, nextcloudpi seems rather different than an old school linux, as it uses docker or snappy, so I’m interested in how you installed jellyfin? Directly from deb-packages, have you added the sources.list and run apt install jellyfin or is there some kind of docker-image or snappy-package you started? Depending on this, all directories mentioned may be different, or even inside some kind of image, container or package.

Best regards,
Benchlor

Hi,
I’m also experiencing the same issue here trying to install jellyfin on a raspberry pi 4. I’m using raspbian rather than Nextcloudpi, so I tried installing from the debian repo doing apt install jellyfin.

Systemd says it’s running, but then I cannot reach the server on localhost:8096.

journalctl -xe says it couldn’t find a usable version of libssl

-- The job identifier is 5831 and the job result is done.
Sep 30 21:40:46 raspberrypi systemd[1]: Started Jellyfin Media Server.
-- Subject: A start job for unit jellyfin.service has finished successfully
-- Defined-By: systemd
-- Support: https://www.debian.org/support
-- 
-- A start job for unit jellyfin.service has finished successfully.
-- 
-- The job identifier is 5831.
Sep 30 21:40:48 raspberrypi jellyfin[4725]: [21:40:48] [INF] Jellyfin version: 10.3.7.0
Sep 30 21:40:48 raspberrypi jellyfin[4725]: [21:40:48] [INF] Arguments: ["/usr/lib/jellyfin/bin/jellyfin.dll", "--restartpath=/usr/lib/jellyfin/restart.sh", "--ffmpeg=/usr/lib/jellyfin-ffmpeg/ffmpeg", ""]
Sep 30 21:40:48 raspberrypi jellyfin[4725]: [21:40:48] [INF] Operating system: Linux 4.19.66.7
Sep 30 21:40:48 raspberrypi jellyfin[4725]: [21:40:48] [INF] Architecture: Arm
Sep 30 21:40:48 raspberrypi jellyfin[4725]: [21:40:48] [INF] 64-Bit Process: False
Sep 30 21:40:48 raspberrypi jellyfin[4725]: [21:40:48] [INF] User Interactive: True
Sep 30 21:40:48 raspberrypi jellyfin[4725]: [21:40:48] [INF] Processor count: 4
Sep 30 21:40:48 raspberrypi jellyfin[4725]: [21:40:48] [INF] Program data path: /var/lib/jellyfin
Sep 30 21:40:48 raspberrypi jellyfin[4725]: [21:40:48] [INF] Web resources path: /usr/lib/jellyfin/bin/jellyfin-web/src
Sep 30 21:40:48 raspberrypi jellyfin[4725]: [21:40:48] [INF] Application directory: /usr/lib/jellyfin/bin/
Sep 30 21:40:48 raspberrypi jellyfin[4725]: No usable version of the libssl was found
Sep 30 21:40:48 raspberrypi systemd[1]: jellyfin.service: Main process exited, code=killed, status=6/ABRT
-- Subject: Unit process exited
-- Defined-By: systemd
-- Support: https://www.debian.org/support
-- 
-- An ExecStart= process belonging to unit jellyfin.service has exited.
-- 
-- The process' exit code is 'killed' and its exit status is 6.
Sep 30 21:40:48 raspberrypi systemd[1]: jellyfin.service: Failed with result 'signal'.
-- Subject: Unit failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
-- 
-- The unit jellyfin.service has entered the 'failed' state with result 'signal'.
Sep 30 21:40:48 raspberrypi systemd[1]: jellyfin.service: Service RestartSec=100ms expired, scheduling restart.
Sep 30 21:40:48 raspberrypi systemd[1]: jellyfin.service: Scheduled restart job, restart counter is at 2.
-- Subject: Automatic restarting of a unit has been scheduled
-- Defined-By: systemd
-- Support: https://www.debian.org/support
-- 
-- Automatic restarting of the unit jellyfin.service has been scheduled, as the result for
-- the configured Restart= setting for the unit.
Sep 30 21:40:48 raspberrypi systemd[1]: Stopped Jellyfin Media Server.
-- Subject: A stop job for unit jellyfin.service has finished
-- Defined-By: systemd
-- Support: https://www.debian.org/support
-- 
-- A stop job for unit jellyfin.service has finished.
-- 
-- The job identifier is 5896 and the job result is done.
Sep 30 21:40:48 raspberrypi systemd[1]: Started Jellyfin Media Server.
-- Subject: A start job for unit jellyfin.service has finished successfully
-- Defined-By: systemd
-- Support: https://www.debian.org/support
-- 
-- A start job for unit jellyfin.service has finished successfully.
-- 
-- The job identifier is 5896.

Finally, the jellyfin log shows

:~ $ tail /var/log/jellyfin/jellyfin.log 
[2019-09-30 21:56:04.985 +01:00] [INF] Jellyfin version: "10.3.7.0"
[2019-09-30 21:56:05.076 +01:00] [INF] Arguments: ["/usr/lib/jellyfin/bin/jellyfin.dll", "--restartpath=/usr/lib/jellyfin/restart.sh", "--ffmpeg=/usr/lib/jellyfin-ffmpeg/ffmpeg", ""]
[2019-09-30 21:56:05.110 +01:00] [INF] Operating system: "Linux" "4.19.66.7"
[2019-09-30 21:56:05.111 +01:00] [INF] Architecture: Arm
[2019-09-30 21:56:05.119 +01:00] [INF] 64-Bit Process: False
[2019-09-30 21:56:05.120 +01:00] [INF] User Interactive: True
[2019-09-30 21:56:05.120 +01:00] [INF] Processor count: 4
[2019-09-30 21:56:05.121 +01:00] [INF] Program data path: "/var/lib/jellyfin"
[2019-09-30 21:56:05.122 +01:00] [INF] Web resources path: "/usr/lib/jellyfin/bin/jellyfin-web/src"
[2019-09-30 21:56:05.123 +01:00] [INF] Application directory: "/usr/lib/jellyfin/bin/"

Any help is very much appreciated.
Thanks.

Can’t verify this myself, because all my pi’s are in usw, but look at this https://www.reddit.com/r/jellyfin/comments/cbjfqy/comment/etgnnrz

Good luck! :wink:

I already installed Jellyfin with Docker, but then I tried installing libssl1.0.2, as suggested
sudo apt install jellyfin libssl1.0.2
and that did the trick. It werks!

Thanks!!