Password reset not working with PIN

I’m running in a docker, with an admin account that only gets used to admin other users. Other users don’t have passwords on them because I don’t have anything NATed through to the wifi (everything’s done via VPN).

All of a sudden, my admin account quit allowing me to sign in. I went through the steps to reset the password, found the json file, entered the password. The system says that the password was reset and that I should be able to log in using the PIN, but the PIN doesn’t work.

I’ve entered it with dashes, and without. It doesn’t seem to care if the dashes exist or not in order to get it to accept the pin to reset, but nothing I try works to actually log in. It accepts the pin, the json file disappears, but no combination of PIN with or without dashes, or with or without caps, ever works.

What am I missing?

Anybody? Hoping to avoid a complete reinstall from scratch to be able to manage my libraries. :frowning:

Okay, that’s a weird one. I have a theory but we want to get you in, not spend time testing theories.

There should be a folder with user config data. I know on regular Linux installs, this is located at /etc/Jellyfin/. Inside there is a file, system.xml.

Near the top, one of the lines will be about the first time setup wizard. Set it to false. Restart Jellyfin.

When you go to the site, it will take you through making a new admin account. Give it a different name, like “wrenchmonkey2”. Login with this new Admin.

Get to the dashboard, and reset the password on your old admin account. Now sign out, login as your original account, and delete the new one.


If you really felt like helping us figure out what happened, before you do this reset business, look in the config folder for the “users” folder. There should be another one with your user name. Inside, there is a policy.xml file. Save a copy of it, and send it to me for review. You can PM me if you want.

1 Like

Perfect, thanks. In the binhex-jellyfin docker I’m using, I found the file under /config/config/system.xml, (in case anybody else needs to know where to find that file in Docker).

Was able to get the reset to work (thanks!), but now it’s gone and granted admin rights to all users, including my kids’ account (definitely not kosher).

When I try to make changes to that setting, and click save, I just get a spinning colored ring, indefinitely. The settings never save and take effect.