Server name using reverse proxy

I’ve set up jellyfin via docker container and also a letsencrypt container. Both working fine

On my tablet (via 4G), i can enter my duckdns subdomain name in a browser and it opens my jellyfin homepage - Great.

But - on the app, what do i put for the server name to connect to??

I’ve tried https://subdomain.duckdns.org - No go, also tried with /jellyfin at the end

Is there something i’m missing??

You should put it in exactly as it is in the browser. I know you’re using a reverse proxy, but is there a port option you’re missing?

Also check our documentation. You may be missing a field for websockets or similar.

See: https://jellyfin.org/docs/general/networking/index.html

In my browser (outside of home network) i put:
Subdomain.duckdns.org
And it works, but using that same adress in the app, says cant connect to server

Ill look through the docs again!

Checked through all the docs and have everything set as per instructions.

Only way subdomain name works is via browser
If i use the app (android) i get “Connection Failure, unable to connect to selected server right now. Make sure its running and try again”
Server is definitely running!

This is the error i get from unraid jellyfin docker logs, when trying to access jellyfin via android app:

So you’re putting the exact same “http://subdomain.duckdns.org” in the app and is isn’t working? I’ll have to ask our folks on that.

Thats correct!

On a side note - i stopped the letsencrypt docker container, installed NginxProxyManager docker container. Setup same DNS name and same port forwarding, and it works using the app!
Not sure what the differences are!

Okay, interesting. Something for us to explore then. Thanks for the update!

1 Like