APP not working

Hello there :slight_smile:

I just realized my local musicstreaming with Jellyfin, great thing.

But i’ve got a Problem. I tried to connect from my Android Smartphone via APP (F-Droid Store) with DLNA Player (Audinaut, Amdroid, D-Sub) but none of these apps is able to connect to the server. I Tried http:192.XXXX:8096 an 192.XXXX:1900.

I am using an android without google (LineAge OS with F-Droid Store) , so not using Playstore.

Is it working at all with these apps? What am i’m doing wrong?

I Would be very pleased to find a solution.

Thank you very much.

We have a version of our Android app being made for the F-Droid Store. Won’t be much longer now.

1 Like

I should add - you can always download it and install it manually from our website: https://repo.jellyfin.org/releases/client/android/

Because you don’t have the Play Store APIs, you can use the “Libre” version.

1 Like

Ah, that really cool. Thank you. It is working properly now.

One other thing… Is there any chance to reduce the Bitrate inside the network? I am using flac, when i am streaming via mobile (VPN) i would like to reduce the Bitrate to safe Datavolume…

The only thing i found is the option to reduce it using a connection from outside the homenetwork.

In the server dashboard under Networking, you should be able to specify which subnets are considered local.
Assuming your VPN addresses are on a different subnet than your LAN, you should be able to control it this way. (It should default to this behavior according to the help text, but I have not tested it myself.)

Bitrate limit is under Playback -> Streaming on the dashboard.

1 Like

Hey thank you.

I did try that. If i put my LAN and WLAN IP Range in the Networking section to specify my local network, i cant get access via OPENVPN.

I suppose it is not working that way…:confused:

I do not want to open the server for public access…

Expand your local network to cover a /23 or even a /16 range instead of the “traditional” /24, and update the network settings on all of your LAN-collected equipment to reflect this - then stick your OpenVPN mapped IP into the newly-created space on your LAN but only specify the old range in Jellyfin.

For example…

Your LAN is currently at 192.168.0.0/24 (meaning it occupies 192.168.0.0 to 192.168.0.255). Change the netmask on all connected devices from 255.255.255.0 to 255.255.254.0 - this will expand your LAN range to go all the way up to 192.168.1.255.

Now, stick the OpenVPN landing IP up in the 192.168.1.x range, but leave the “LAN Networks” definition in Jellyfin set to just 192.168.0.0/24. The OpenVPN connection will have access to your entire LAN, but Jellyfin will calculate its bandwidth restrictions as if it was an external connection.

1 Like

Thank you so much for responding.

This sound kind of compliacted. My “Problem” is, i am using IPFIRE, i think i only can change the netmask during installation. Is there any other chance without changing the subnetmask?

I am using for something like LAN: 192.168.210.1/24 , WLAN: 192.168.140.1/24 VPN:10.163.79.0/24

If your VPN range is already in a different subnet (10.x.x.x instead of 192.168.x.x), it’s easy - just make sure that IPs in the 10.x.x.x range aren’t listed in the “LAN Networks” section of Jellyfin.

Under networking,

  • Make sure to disable Enable automatic port mapping.
  • Enable Allow remote connections to this Jellyfin Server.
  • Optionally add the VPN netmask to Remote IP address filter
    and make sure Remote IP address filter mode is set to whitelist.

Do not put the VPN IP range to LAN networks, only the LAN and WLAN ones.

This should allow you to limit the bandwith for clients on the VPN, while not exposing the server to the internet.

I made a mistake. The used IP Range of VPN is 192.168.34.0/24 (is that a problem? )

So i did put my lan and wlan (192.168.200.1/24, 192.168.150.1/24) to local network.

If i just do that, i cant get acces from my mobile (there comes the message forbidden in the browser).

After activating remote, putting 192.168.34.0/24 to the adress filter, disableing automatic port mapping, setting whitelist mode i get accsess via mobile.

But…if im playing a flac file, the bitrate (set to 128) s still not reduced :confused:

Do i have to activate anything in the transcoding section?

Just a Feedback.

It is working now. I don’t really know why, but it works;) I changed the OpenVPN to10.163.79.0/24, activated Remoteconnection, an set 10.163.79.0/24 to the whitelist of remotacces.

Thank you so much! It is really great work!

One very last question to the topic. If i activate Remote, is there still no access from the Internet without OpenVPN? I hust want to make really sure, the network is “secure” against the outside.

That’s right. The setting you want to have disabled is “Enable automatic port mapping”.

“Allow remote connections to this Jellyfin Server” is fine. You’ll need that one.