Broken Jellyfin following Debian Buster update (Web GUI black))

Following a recent update to version 10.7.0 on my Debian Buster machine, I now have a nie black screen when I call my Jellyfin server via the browser.
Also Jellyfin App on Android shows a black screen. All was working perfectly before the update.

Below a cat /var/log/jellyfin/jellyfin20210311.log after running /etc/init.d/jellyfin start … there doesn’t seem to be any particular line suggesting issues. No errors.

Any thoughts? Should I be filing a bug report? An update of a stable release on a stable distro should not be breaking Jellyfin?

[2021-03-11 12:25:22.544 +00:00] [INF] Operating system: "Linux"
[2021-03-11 12:25:22.544 +00:00] [INF] Architecture: X64
[2021-03-11 12:25:22.545 +00:00] [INF] 64-Bit Process: True
[2021-03-11 12:25:22.545 +00:00] [INF] User Interactive: True
[2021-03-11 12:25:22.545 +00:00] [INF] Processor count: 4
[2021-03-11 12:25:22.545 +00:00] [INF] Program data path: "/var/lib/jellyfin"
[2021-03-11 12:25:22.545 +00:00] [INF] Web resources path: "/usr/share/jellyfin/web"
[2021-03-11 12:25:22.545 +00:00] [INF] Application directory: "/usr/lib/jellyfin/bin/"
[2021-03-11 12:25:22.730 +00:00] [INF] Setting cache path: "/var/cache/jellyfin"
[2021-03-11 12:25:22.776 +00:00] [INF] Defined LAN addresses : "[127.0.0.1/8,10.0.0.0/8,172.16.0.0/12,192.168.0.0/16]"
[2021-03-11 12:25:22.777 +00:00] [INF] Defined LAN exclusions : "[]"
[2021-03-11 12:25:22.777 +00:00] [INF] Using LAN addresses: "[127.0.0.1/8,10.0.0.0/8,172.16.0.0/12,192.168.0.0/16]"
[2021-03-11 12:25:22.778 +00:00] [INF] Using bind addresses: "[]"
[2021-03-11 12:25:22.778 +00:00] [INF] Using bind exclusions: "[]"
[2021-03-11 12:25:22.805 +00:00] [INF] Loading assemblies
[2021-03-11 12:25:25.496 +00:00] [INF] Loaded plugin: "OMDb" "10.7.0.0"
[2021-03-11 12:25:25.497 +00:00] [INF] Loaded plugin: "MusicBrainz" "10.7.0.0"
[2021-03-11 12:25:25.497 +00:00] [INF] Loaded plugin: "AudioDB" "10.7.0.0"
[2021-03-11 12:25:25.580 +00:00] [INF] Kestrel listening on "Any IP4 Address"
[2021-03-11 12:25:25.964 +00:00] [INF] Running startup tasks
[2021-03-11 12:25:26.037 +00:00] [INF] Daily trigger for "Extract Chapter Images" set to fire at 03/12/2021 02:00, which is 13:34:33.963046 from now.
[2021-03-11 12:25:26.104 +00:00] [INF] Found ffmpeg version "4.3.1"
[2021-03-11 12:25:26.133 +00:00] [INF] Available "decoders": ["h264", "h264_qsv", "h264_cuvid", "hevc", "hevc_qsv", "hevc_cuvid", "mpeg2video", "mpeg2_qsv", "mpeg2_cuvid", "mpeg4", "mpeg4_cuvid", "msmpeg4", "vc1_qsv", "vc1_cuvid", "vp8_cuvid", "vp8_qsv", "vp9_cuvid", "vp9_qsv", "aac", "ac3", "flac", "mp3"]
[2021-03-11 12:25:26.147 +00:00] [INF] Available "encoders": ["libx264", "h264_amf", "h264_nvenc", "h264_qsv", "h264_v4l2m2m", "h264_vaapi", "libx265", "hevc_amf", "hevc_nvenc", "hevc_qsv", "hevc_vaapi", "mpeg4", "msmpeg4", "libvpx", "libvpx-vp9", "aac", "ac3", "flac", "libmp3lame", "libopus", "libvorbis", "srt"]
[2021-03-11 12:25:26.159 +00:00] [INF] Available hwaccel types: ["vdpau", "cuda", "vaapi", "qsv", "drm", "opencl"]
[2021-03-11 12:25:26.160 +00:00] [INF] FFmpeg: Custom: "/usr/lib/jellyfin-ffmpeg/ffmpeg"
[2021-03-11 12:25:26.162 +00:00] [INF] ServerId: "XXX"
[2021-03-11 12:25:26.279 +00:00] [INF] Executed all pre-startup entry points in 0:00:00.1023572
[2021-03-11 12:25:26.279 +00:00] [INF] Core startup complete
[2021-03-11 12:25:26.465 +00:00] [INF] Executed all post-startup entry points in 0:00:00.185195
[2021-03-11 12:25:26.465 +00:00] [INF] Startup complete 0:00:04.1244734

Solved the problem. Seems like I chose to not update the config file during the update. So, following the tip on this reddit page, I changed the contents of /use/share/jellyfin/web/config.json by deleting all contents in the file and pasting the following:

{

"includeCorsCredentials": false,

"multiserver": false,

"themes": [

{

"name": "Apple TV",

"id": "appletv"

}, {

"name": "Blue Radiance",

"id": "blueradiance"

}, {

"name": "Dark",

"id": "dark",

"default": true

}, {

"name": "Light",

"id": "light"

}, {

"name": "Purple Haze",

"id": "purplehaze"

}, {

"name": "WMC",

"id": "wmc"

}

],

"servers": [],

"plugins": [

"playAccessValidation/plugin",

"experimentalWarnings/plugin",

"htmlAudioPlayer/plugin",

"htmlVideoPlayer/plugin",

"photoPlayer/plugin",

"comicsPlayer/plugin",

"bookPlayer/plugin",

"youtubePlayer/plugin",

"backdropScreensaver/plugin",

"pdfPlayer/plugin",

"logoScreensaver/plugin",

"sessionPlayer/plugin",

"chromecastPlayer/plugin"

]

}

Luckily its all working again now :slight_smile:

Hope this helps others having the same issue.

The Buster update has some other issues. With removal of the /usr/share/jellyfin/web/components folder and the skinManager.js file I’ve lost customizations. I had modified a couple of existing themes in a very simple way just to give wider scrollbars (but on a dark background) as one can see in the Light or Apple TV themes. Even if I add those themes back to /usr/share/jellyfin/web/themes/ and make sure their names are added to config.json, they are not picked up by the server (ie. not offered as User → Display choices). Anyone know how I can solve this?

Additionally IPTV streams will not play. On screen all we can see if the spinning circle. But the logfile says "[ERR] Error processing request: “The process cannot access the file ‘/var/lib/jellyfin/transcodes/7254c3eacb134e6cb6b78d6d1ec6d7e3.ts’ because it is being used by another process”. However there is no other process (unless it is within jellyfin itself) using that transcode. All the while the transcode file keeps getting larger but nothing streams. It is a valid stream and plays fine in VLC.
I have to shutdown jellyfin, close the browser instance and delete the transcode file.

My setup has not changed. I first tried the upgrade path (Debian Buster) and when I received the error just described above decide to purge jellyfin (I have a simple setup) and start fresh with 10.7.0-1. Jellyfin 10.7.0-1 simply will not play the streams (any stream) in my .m3u file.

Here is info from ffmpeg log:
https://drive.google.com/file/d/19Te7gX4_hnqQMo-N7U4hj3QgOiof5797/view?usp=sharing

If anyone might have an idea how the error might be corrected, would appreciate it.

So this confirms the bug for anyone still reading here. I wouldn’t expect Live TV to be any different than IPTV from a streaming point of view: