Can’t run Jellyfin on macOS 10.14.6

Hello, when I launch Jellyfin from the launchpad, (after allowing in security preferences) it says that Jellyfin quit unexpectedly, so I click reopen. Then when I select launch web ui from Jellyfin taskbar, Safari David to open page localhost:8096 “can’t connect to the server”
Activity monitor doesn’t list it as running.
I hope you can help. My HDHomeRun subscription is running out and would rather choose Jellyfin over Plex premium.
Thanks

What version of jellyfin are you running? I know there’s been some changes to the macOS package?

The latest stable 10.4.1

Hey there!
I’m the packager for macOS. I had tested this as working and signed on Mojave and Catalina so I’m not sure what’s happening…

Just to confirm:

  • are you now able to launch the tray app with it closing?
  • when the tray app is open, does Jellyfin appear anywhere in Activity Monitor?
  • If the tray app is open, could you use the “Show Logs” button, and grab the most recent one for me to review?

You can PM me a link to the logs, or post the link here. Make sure to open it in something like TextEdit first and take out any info you don’t want us to see (username, domain, etc)

Hi Anthony, Ive pm’ed you a link to a log. its an apple log as “show log” button didn’t work.
Jellyfin couldn’t start, it is not in activity monitor. I’m not sure what you mean about launch the app tray with it closing? I placed the app into app bar, but that didn’t work either. the jellyfin icon appears on the top system bar but it doesn’t appear to be “on”
thanks for your help

if its of anymore help, I needed to go into security and privacy settings on mac to allow it to open jellyfin when i first opened after moving to application folder. as it says its not a known developer or something like that

Sorry about that, I meant the menu bar. I was spending too much time debugging the Windows Tray app :upside_down_face:

The Apple log is… interesting. I’m trying to debug more about it. I also just uploaded a Jellyfin 10.4.2 version, could you try that?

Thanks Anthony, just tried 10.4.2. But still the same unfortunately

Try this for me:

  • find the Jellyfin app in the applications folder
  • right click it and choose “show package contents”
  • go in to the resources folder
  • go in to the Jellyfin folder
  • double click on just “Jellyfin” and see what happens

If that fails, try the regular non-DMG version. Just unzip it somewhere safe (like a folder in Applications) and try running that. See if it launches properly or not. If not, then there should be some kind of log or other information.

Ok, I’ve done what you said, a terminal screen popped up, then safari opened with the welcome to Jellyfin page.
I’ve had a look through the terminal commands and one line says, FFmpeg: NotFound: (in green) is that an issue?
Also will closing the terminal end Jellyfin? Also if I had to restart the computer, will Jellyfin auto start doing it this way?
Cheers

Also Jellyfin shows in activity monitor but not on The menu bar. I haven’t gone through the setup yet though

@brabs Okay, so that means that the Jellyfin file inside the .app works…

The FFMpeg thing is expected, because I package it inside the app, and when you run Jellyfin manually, it doesn’t know where to find it.

As far as closing it goes, yes, closing the terminal would close Jellyfin. It will not autostart this way. I just wanted to see if this worked at all. This is just manually starting the Jellyfin application that is inside the .app, so that’s also why the menu bar icon wouldn’t show.

If you close it, and try the .app again, does it still crash? This is getting me closer to a fix.

Yes it still crashes when trying to launch again.
I have copy and pasted the terminal text as there were a few other errors showing in it. I’ll send you a link via pm

Same. It doesn’t run or work at all.

Followed your instructions @anthonylavado and a system alert pops up that says “This developer is not authorized” Once I authorized you, it’s running. But that dialog never sees the light of day when you run the app normally.

That’s really strange because I go to great lengths to make sure everything is signed… I just don’t understand.

By the way - and this goes for anyone looking at this thread - just running Jellyfin on its own from inside the resources is just a troubleshooting step, I don’t recommend doing that for day to day use.

Just trying to figure out what could be going on with this menu bar app.