Depository dependencys not working on Coreelec 9.2.5

Hello,

I just installed Coreelec 9.2.5 (Kodi 18.9) on my new X96Max+ and it looks like it is all working

I however seem to have a problem installing the Jellyfin addon,

I used the same methode I dit for my previous coreelec install.

first manualy install the jellyfin repository (that works fine)

but than when I go to install the jellyfin addon, it refuses to get any dependency’s , I have manualy installed the first one, but than it also wont get the second one :frowning:

message in my log ;

2020-11-06 14:59:49.356 T:4064641040 DEBUG: CAddonInstaller: installing ‘plugin.video.jellyfin’ version ‘0.6.3+py2’ from repository ‘repository.jellyfin.kodi’
2020-11-06 14:59:49.362 T:3827413888 DEBUG: CAddonInstallJob[plugin.video.jellyfin]: requires script.module.requests version 2.22.0 which is not available
2020-11-06 14:59:49.363 T:3827413888 ERROR: CAddonInstallJob[plugin.video.jellyfin]: The dependency on script.module.requests version 2.22.0 could not be satisfied.
2020-11-06 14:59:49.398 T:4064641040 DEBUG: CGUIMediaWindow::GetDirectory (addons://repository.jellyfin.kodi/xbmc.addon.video)
2020-11-06 14:59:49.398 T:4064641040 DEBUG: ParentPath = [addons://repository.jellyfin.kodi/xbmc.addon.video]
2020-11-06 14:59:49.399 T:3704038272 DEBUG: Thread waiting start, auto delete: false
2020-11-06 14:59:49.402 T:3704038272 DEBUG: CAddonDatabase: SELECT repo.id FROM repo … took 0 ms
2020-11-06 14:59:49.403 T:3704038272 DEBUG: CAddonDatabase: query SELECT * FROM addons JOIN addonlinkrepo ON addons.id=addonlinkrepo.idAddon WHERE addonlinkrepo.idRepo IN (4) ORDER BY addons.addonID returned 27 rows in 1 ms
2020-11-06 14:59:49.404 T:3704038272 DEBUG: CAddonDatabase::GetAddons took 2 ms
2020-11-06 14:59:49.417 T:3704038272 DEBUG: CAddonMgr::GetAvailableUpdates took 13 ms
2020-11-06 14:59:49.418 T:3704038272 DEBUG: Thread waiting 3704038272 terminating
2020-11-06 14:59:49.425 T:3704038272 DEBUG: Thread BackgroundLoader start, auto delete: false
2020-11-06 14:59:49.426 T:4064641040 DEBUG: ------ Window Init (DialogNotification.xml) ------

Other addons from the build in depository’s seem to get there dependency’s just fine.

Is there a new jellyfin depository installer to fix this ?

Let me know please,

Thank you,

Hans

Those of us doing Kodi dev and re-installing a bunch have all seen this a few times, and the only real explanation we’ve found is that sometimes Kodi’s addon mirrors get a little out of whack. Which is a bummer since it means there’s nothing we can do ourselves to prevent it. Usually waiting a few hours should let it go through correctly. Sometimes if you nuke the ~/.kodi directory of your install and try again, the next time it reaches out it will pull from a different mirror and work properly.

Thank you very much,

As you predicted, it just works today without changing anything :slight_smile:

Weird,

but happy it now works,

thank you,

Hans