High cpu usage doind nothing

Hi, new user here.
I have decided to install Jellyfin and I like it so far, specially hardware transcode without a suscription. Still I am having an issue
/usr/bin/jellyfin --restartpath=/usr/lib/jellyfin/restart.sh --ffmepg=/usr/lib/jellyfin
on htop it shows up multiple times, cpu usage is around 25% , library is EMPTY, no folders, nothing.
tried searching forum but not answer so i created a topic.
installed on a debian machine
any suggestions, appreciated.

Im not sure, but try and disable IPv6:
Open anl (CTRL + ALT + T and write:
sudo nano /etc/sysctl.conf
On an empty line write:
net.ipv6.conf.all.disable_ipv6 = 1
Use these keyboard shortcuts to save and close nano editor:
CTRL + O (Gemmer) og CTRL + X (Luk nano)
enable it by entering this command:
sudo sysctl -p

Not tested on Debian, but worked on my Raspbian (Based on Debian)

thanks, but stll no difference
after restarting that and jellyfin, same issue

I am having the same issue. Just installed 10.5.5-1 in Ubuntu 20.04. I haven’t configured anything, haven’t added any directories to scan, simply installed from the jellyfin repo per instructions and the bare install keeps CPU (i7-4770) slightly busy at ALL times.

This was my attempt to jump off Plex but I don’t really want my computing resources being used for no reason. I guess I’ll try Jellyfin again maybe in a few months or so.

  • What does Jellyfin’s log file say that it’s doing?
  • Precisely which instructions did you use to install (there’re several sets floating around)?

I’m onto my second Jellyfin installation (after a complete hardware upgrade) on far more restrictive hardware than what you’re using (ESXi VM with only two CPU vcores and 4Gb RAM) and it doesn’t flinch - idles at between 0% and 0.3% CPU usage.

Yeah, I have to agree with @Cognicom here - that is not typical, and is not something we’ve seen in other installs (and we set up a bunch of blank installs regularly to test things).

I am keeping Jellyfin after all. As I disabled remote access CPU usage went down. It is still not entirely 0 when idle but it is acceptable.

I wonder why simply enabling remote access adds so much overhead.

Did you already have port 8096 forwarded from your router? Because it’s not straightforward to change Jellyfin’s HTTP port, and because most users are relative newcomers to packages like this (and therefore use trivial passwords), it wouldn’t surprise me if your machine was being pummelled by hack attempts.

If you didn’t already have the port forwarded, then there’s obviously something else there that’s a concern. Jellyfin’s log files (when remote access is enabled) may hold a clue; if they don’t, some deep process inspection may be in order, to see exactly what’s eating the cycles.

Neither I had port forwarding set up nor the machine was on DMZ.

To my surprise I just re-enabled remote access and now the CPU utilization stayed low. As it should. Must be something to do with a fresh install.

There seem to be other reports of high CPU usage related to enabled remote connections: https://github.com/jellyfin/jellyfin/issues/2589