Jellyfin app can't login

Hi, for somereason I can’t seem to login to the app.

  1. I can connect and login by local ip address.(app)

  2. When using external ip address I can connect to the server but login fails(app)

  3. When using a web browser form external ip address I can connect and login. … just not the app what could be wrong?

Thanks
Nissan

Which app? Regular Android, or Android TV?

Are you on the latest 10.4.1? Do you use a reverse proxy at all?

and now, probably the easiest suggestion, what happens if you put /jellyfin at the end of the URL?

Hi I’m using, 10.4.1 with android app (mobile)

No proxy server.

/jellyfin = Unable to find the specified file

Could it be I’m using a dns to point to my public ip?

Noip = is set to a record with port 8096

cant seem to resolve the issue anything else i can try?

in the app type: “http://yourserverip:port/jellyfin” and ignore the second part where it ask for port (make it blank).

I hope that this helps.

BTW which version of the app have you installed PLAY STORE or the standalone apk?

Hey Anthony, I just checked apparently it (android app) can no longer dynamically switch between local and external IP.

yes its only works on local host ip.

The app is able to see the server just not login using a dns (noip) or domain address with A record which repoints to public IP.

Thanks
Nissan

I have this exact problem, only with the use of a reverse proxy.
Tried different suggestions. In Chrome mobile browser I can add the server externally and login, the Android app does connect to the server externally but I can’t get past the login.

I am aware of the BaseUrl changes in 10.4.1 but I don’t understand this.

@Dbz195 did you ever get this to work?

After some tinkering I resolved this by adding some security settings in my Caddy reverse proxy config, which apparently seems to solve this Android client login problem:

header /jellyfin/ {
-Server
Strict-Transport-Security “max-age=31536000;”
Referrer-Policy “strict-origin”
X-XSS-Protection “1; mode=block”
X-Content-Type-Options “nosniff”
X-Frame-Options “DENY”
}

Don’t know which part did it for me but I’m satisfied.