New User Problems accessing shares

Hi Hope someone can help . I’m trying various ways to set up Jellyfin but each method has me beaten.
I have a QNAP NAS and tried to install via its Container Staion using Docker but I’ve run in to problems because having installed the jellyfin image I dont underatand how I can mount the media folders contained on the NAS. My movies for example are contained in a folder /Multimedia/movies but how do I mount this? Jellfin Gui just shows “media” which points to nothing.

Second attempt on Windows 10,installed OK but again no way I can see to mount my Networked shares from the NAS.Jellyfin just shows c: drive or Network and network doesn’t do anything?

Third attempt with Dietpi. Installed OK and mounted the multimedia folder on the piJellyfin shows folder mounted as Multimedia but can’t gain access to contents.
I’m baffled so would appreciate any help offered.
Thanks

  • QNAP: This is pretty platform specific so I can’t give you details instructions, but the root of the issue is that you have to pass your media directory into the docker container as volumes. I’m not sure how this is accomplished with qnap, as I’m only familiar with command line docker

  • Windows: You’d need to mount the shares to a windows drive letter before Jellyfin can see them. Jellyfin isn’t able to read NFS/Samba mounts directly, they need to be mounted to a local folder in the OS and then Jellyfin can read that local mountpoint.

  • Dietpi: Sounds like you were on the right track. Jellyfin runs as it’s own user which likely didn’t have permissions to view your media. You can test this by doing sudo -u jellyfin ls /path/to/media. If it isn’t able to, you’ll need to either adjust the permissions on your files or add the jellyfin user to a group that does have permissions. For example, if your files have ownership of rod:users, you can try adding the jellyfin user to the users group.

Thanks very much for your suggestions. I’ll try with Dietpi tomorrow as Windows isn’t my preferred choice and whilst the Qnap server is it’s beyond my skills to setup in docker.

Hi, I don’t know it will help you, but I am currently using jellyfin server in windows 10 pro machine and maybe this tips will help you, to access your NAS.

The easiest way is just browse your remote folder file explorer, than right click and choose map drive.
Screen Shot 2020-12-06 at 11.59.24

After you add the drive letter, you can access it like an ordinary drive from file explorer or from your jellyfin add library.

Hope its help

Thanks for your suggestions. I’ve being playing around with Dietpi over the weekend and setup Samba to access the NAS shares whereas I’d previously tried with NFS and couldn’t connect. I’ve got it working on the Pi now and that’s probably my best option as I can leave the Pi running whereas Win 10 I wouldn’t want always on.
Appreciate your help though.