Reverse Proxy goes to SERVER_NAME/web/index.html

Hi there,
I recently installed Jellyfin (I’m a newbie) and put it behind a reverse proxy. The Reverse Proxy goes to EXTERNAL_SERVER_NAME/web/index.html and returns a 404. If I go directly to the jellyfin server by IP I get SERVER_IP/web/index.html#!/login.html?serverid=…
Any help with this would be greatly appreciated

External server RHEL 7.3
Jellyfin media server on CENTOS 7

What reverse proxy are you using? We have lots of sample configurations at https://docs.jellyfin.org

I am using Apache 2.4 on RHEL 7.3.

Can you share your apache config ?

My log looks like this when I try to access it from outside the lan

[2020-01-14 15:23:18.344 -06:00] [ERR] Error processing request: "Access token is invalid or expired."
[2020-01-14 15:23:18.345 -06:00] [ERR] Error processing request: "Access token is invalid or expired."
[2020-01-14 15:23:18.348 -06:00] [ERR] Error processing request: "Access token is invalid or expired."
[2020-01-14 15:23:18.349 -06:00] [ERR] Error processing request: "Access token is invalid or expired."

In your config you have ProxyPass “/jellyfin” but then passing that to a url without that, are you wanting your jellyfin instance on a path of the domain then? If that’s so do you have it set in the jellyfin server settings?

Thank you so much dude, that fixed the issue - that, and removing the Centos 7 install and replacing it with Ubuntu 18.04.

And this years idiot of the year goes to … wait for it … me!!

Cheers

1 Like

I am using EL7 as well, no problems with the apache reverse proxy. Sanitized somewhat.

<VirtualHost *:80>
ServerName jellyfin.FQDN
ErrorLog /var/log/httpd/jellyfin.FQDN-error.log
CustomLog /var/log/httpd/jellyfin.FQDN-access.log combined
RewriteEngine on
RewriteCond %{SERVER_NAME} =jellyfin.FQDN
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

ServerName jellyfin.FQDN
ProxyPreserveHost On

ProxyPass "/socket" "ws://HOST_IP:8096/socket"
ProxyPassReverse "/socket" "ws://HOST_IP:8096/socket"

ProxyPass "/" "http://HOST_IP:8096/"
ProxyPassReverse "/" "http://HOST_IP:8096/"

SSLEngine on
#Protocols h2 http/1.1

ErrorLog /var/log/httpd/jellyfin.FQDN-error.log
CustomLog /var/log/httpd/jellyfin.FQDN-access.log combined
SSLCertificateFile /etc/letsencrypt/live/FQDN/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/FQDN/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf
SSLCertificateChainFile /etc/letsencrypt/live/FQDN/chain.pem

Thanks Schotty and everyone for you help. It is working great now.

1 Like