Revese proxy problem

I want to run the jellyfin server under a sub directory behind reverse proxy. After reading docs in https://jellyfin.org/docs/general/administration/reverse-proxy.html?q=reverse , I did some configuration as follows,it just can’t work right:

ProxyPreserveHost On

            ProxyPass "/socket" "ws://127.0.0.1:8096/socket"
            ProxyPassReverse "/socket" "ws://127.0.0.1:8096/socket"

            ProxyPass "/jellyfin" "http://127.0.0.1:8096"
            ProxyPassReverse "/jellyfin" "http://127.0.0.1:8096"

when I type in server.name/jellyfin in browser, it jumps to server.name/web/index.html with a 404 error. If I change it manually to server.name/jellyfin/web/index.html, I can get access to jellyfin.
info as follow:

server: apache2.4
https: enabled
http redirect to https: enabled

How to make server.name/jellyfin jump to the correct url?

Ahh the setting you’re looking for is called “Base URL”, and it’s a change you make inside Jellyfin, not the Apache config.

Go to the Dashboard, and scroll down to Networking. It’s in there. Once you change it, restart Jellyfin. Note that some clients don’t work with this, like Sonarr and Radarr.

Actually I’ve tried that but it didn’t work. However, I managed to set up a reverse proxy by using another second-level domain and proxy the 8096 port to a new domain. Thank you anyway.