Subtitles problem

#1

Hi everyone

I’m new to Jellyfin, I discovered it few days ago and I like it! It’s what I need.
I installed it on my archlinux through aur and it worked pretty well.

The only problem for me is the subtitles. I have the movie, and the srt file next to it with the same name. It works in VLC, Jellyfin detects the srt file… but it’s not showing up. I found this solved bug but I see nothing in my logs and the installed version is 10.2.2 (it should be fixed).

I would like to check if there is something I’m missing before reporting a bug. Any idea?

#2

Replying to myself, it has to do with the browser. I use Vivaldi (based on chrome engine), when I use firefox the subtitles appears. I still don’t know the root of the problem.

Update: My browser didn’t get the correct ffmpeg libraries, so HTML5 tag wasn’t working properly. installing them solved the problem. :smiley:

2 Likes
#3

How do you install the ffmpeg libraries? I had the same issue with Chrome and subtitles.

#4

Depends on your OS and browser, in my case, I have Arch and Vivaldi, so I installed the package vivaldi-ffmpeg-codecs
yaourt -S vivaldi-ffmpeg-codecs

Chrome has it own ffmpeg embedded as far as I know, so check if your browser has support for all html5/codecs videos, for example here

My browser was missing one of them, and installing the ffmpeg plugin for vivaldi was the solution. If it’s your case, look for how to support the missing codec in chrome and in your operative system. Hopefully by fixing it, subtitles and jellyfin will work flawless.