Troubleshooting launching Jellyfin

Good Morning,

I’ve tried using the centos version and obtained the relevant rpm’s if necessary, i’ve even tried using the linux portable version.

Every time I launch Jellyfin i get the following error. I can’t resolve it…
I’m currently on [INF] Jellyfin version: 10.4.1

[06:25:17] [ERR] Error creating http port map
System.Net.Http.HttpRequestException: The server returned an invalid or unrecognized response.
   at System.Net.Http.HttpConnection.ThrowInvalidHttpResponse()
   at System.Net.Http.HttpConnection.ParseStatusLine(Span`1 line, HttpResponseMessage response)
   at System.Net.Http.HttpConnection.SendAsyncCore(HttpRequestMessage request, CancellationToken cancellationToken)
   at System.Net.Http.HttpConnectionPool.SendWithNtConnectionAuthAsync(HttpConnection connection, HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken)
   at System.Net.Http.HttpConnectionPool.SendWithRetryAsync(HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken)
   at System.Net.Http.RedirectHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
   at System.Net.Http.HttpClient.FinishSendAsyncUnbuffered(Task`1 sendTask, HttpRequestMessage request, CancellationTokenSource cts, Boolean disposeCts)
   at Emby.Server.Implementations.HttpClientManager.HttpClientManager.SendAsyncInternal(HttpRequestOptions options, HttpMethod httpMethod)
   at Emby.Server.Implementations.HttpClientManager.HttpClientManager.SendAsync(HttpRequestOptions options, HttpMethod httpMethod)
   at Mono.Nat.Upnp.UpnpNatDevice.CreatePortMap(Mapping mapping)
   at Emby.Server.Implementations.EntryPoints.ExternalPortForwarding.CreateRules(INatDevice device)

So this message usually happens when one of two things is happening:

  1. Something is already running on port 8096, like Emby
  2. There is already a copy of Jellyfin running

Do you know if either is the case? Even if you close this, does anything come up when you go to http://YOURIPHERE:8096 ?

Good Morning,

I’ve checked all ports - I’m not listening on anything in the 80 range.

Many thanks

@dashwell So I recently learned - this message is actually normal and is not a problem.

There’s a setting inside Jellyfin that tries to automatically open the port on your router using UPNP.

If this setting is on, but it can’t create the opening, you’ll get this message saying it couldn’t create the mapping to open the port for HTTP access. So, in other words, it’s safe to ignore.

Good day, Sorry I’ve been very busy with exams. While you say i can ignore it, I can’t get passed it. The system actually stops responding there. I need to terminate the application then. If there is a way i can turn it off on the config I’d be glad. I just can’t even get the app to continue with the launch with it occuring

Since we’ve last spoken, Jellyfin 10.4.3 has been released. Try updating to that. And you’re sure you aren’t running anything else on port 8096?