Couple of questions from a new Jellyfin user

Hi there,

I have been a long time plex user and done several media center setups in the past using Plex and Kodi (and a mixture of both). I currently run plex in the house to several devices and the tv for the family and friends to enjoy my media collection. I was happy until I tried to get live TV into plex - being a non-plex pass user I signed up for a month trial, which even then streams wouldn’t work properly.
I had a go at emby, but came up against a paywall, then I stumbled on the github posting about Jellyfin and gave one of the nightlies a go 4 days ago. Live TV worked pretty much out of the box, and I decided to see how it performs with my media - after a few hiccups (ended up wasting 2 days when setup jellyfin server cleared itself on restart - believe it was user error). I’m growing to like it more and more.

So enough of the babbling, onto the questions:

CPU usage - I’m seeing an average of about 30% CPU usage just from jellyfin.server according to task manager when nothing is happening on the server - it spikes up and down every second or so. I originally thought it was the watching of folders, as the disk usage also bounces together with the CPU, however turning the options off in dashboard/libraries/advanced seemed to not make a difference - the watched folders are indeed off as the cmd window did not show the listing on restart - I restarted pc to make sure that the server is fresh.
Now the PC is not a powerhouse, the other end actually (dual-core no hyperthreading) so fair enough, it’s weak, but Plex is hardly drawing much when nothings happening.

Obviously, I understand its early days, optimizations will come, but just curious what could be causing this constant usage when nothing is going on? - it’s not a deal-breaker, but I would like to minimize the heat if I can (room temps sit between 24 - 32 deg C)

The other question stems from the android app. I attempted to run jellyfin android on the “tv box” (minix x8h running android 5). It worked great until I tried to play the media, to which I get a blank screen with the audio. It might be user error again and plan to try again tomorrow when no one’s home and the tv is not in use, but plex android app works fine with the unit so it must be something simple.

It’s my first post here, so I just wanted to get it out there, help if I can (my PC expertise is with computer construction/troubleshooting for myself, friends and family).

Regards

W.

I’m not sure on the Android TV side, but I can maybe answer on the CPU usage side.

In the Advanced Settings for each library, as well as the Scheduled Tasks, there may be the option to have Screen Grabber on, and possibly extracting chapter images on.

Since this is a fresh install, it might take a bit for these items to “settle”. Then, depending on settings, they might kick in again when something new gets added.

So, I’ll start with the android app first:

After quite a bit of testing on the Android App with various devices, its kinda bad news on this front - with one device it works great - my galaxy s5 phone, but my other devices it can be a pain, in particular with the Minix box I described earlier. It comes up as “chrome android” on the notifications list on the dashboard, not sure if that’s a result of the box having a special ROM for android 5 or not but anyway, I still can’t get picture to show, audio plays fine, and I’ve tried changing the settings on the app to see if any difference is made - but nope, a couple of other things with the app, display info when playing shows it is running in 720p, when its normally set to full HD on the box. Also if you “go back out” from what you are watching, it keeps the last seen picture (black screen in my case) in all the menus/home screen - there are definitely some issues here.
I’m not a coder (my experience stems from learning a bit about C++ as into game development with UE4), but willing to be a guinea pig for testing the app on my troublesome devices (was a tester for windows 7 and 10).

So onto the other issue - the CPU. I took the advice of @anthonylavado and checked the settings in libraries. Disabled screen grabber and ensured chapter image extraction is off and examined the scheduled tasks - nothing running on a repetitive cycle. The CPU still hovering on 30%, however, it has started to peak to 40-45% every so often on one of its “cycles”, so there is something to be had with that.
So I can show how it behaves, I put up a short screen video recording - obviously, the screen recorder software will load the CPU also, but the principle is still there - sorry for the black bar, it was a short quick recording: https://youtu.be/PHy0LGgYnGI
For anyone curious, the Ispy app is my CCTV software watching the front gate

W.

So I ended up posting to the Jellyfin Reddit, and following that found the cause and solution to the CPU cycle problem:

At the moment, running the web app through Firefox android on the TV minix box as it performs the best (Jellyfin android app still gives black screen and audio), Chrome Android plays fine but full screen results in a 4:3 box with black bars on either side - but playing fine so far…

Wodger

Right, so what’s going on with the .EXE? Well, it has to do with our new installer and the way things get set up.

Basically, when you would run Jellyfin manually before, all the configuration files are created under your account name, with those permissions. When you set up Jellyfin with the installer, you’re given two options. You can set it up as “Local System”, or as “Network Service”.

If you set it up as Local System, there won’t be an issue, but it’s not recommended. Why? Local System is essentially root for Windows, giving it access to all your files and everything on your computer. For this reason, the installer recommends “Network Service”. Network Service will work just fine for most cases, but there are a few caveats:

  • It cannot access network share drives without extra configuration on your part
  • It does not have permission to access your old config files, even if you move them to the right area

When the service tries to launch with NSSM.exe in the background, it will try to read the config files in the ProgramData folder. When it can’t access them for permission reasons, Jellyfin will crash and close out. Then, NSSM sees that it has stopped, and it (by default) will wait 1.5s before launching it again, every time.

If you look at the Task Manager while this is happening, you’ll see that Jellyfin.exe keeps going up and down like a yo-yo.

There’s a few fixes you can take right now, while I consider ways to improve the installer:

  1. You can move the config files back to the old location, and just keep running the EXE like usual (disable the service too)
  2. You can add “Network Service” permission to the config folders (some users report that R/W for All Users works too)
  3. You can change the service to “Local System” (which should be low risk, but is up to you to manage)

That’s where it stands right now. I’m still thinking of ways to make it better overall for our Windows users.

Hi mate,

Thanks for responding, at the moment, I’m doing what I posted in the Reddit - the service is disabled and a shortcut to Jellyfin.exe is in the startup folder for all users (although there is only 1 user on this unit so it wouldn’t matter if it was for all users/one user) - it works fine for me, but obviously with what you’ve said its not the best solution - is that right?

The yo-yo behavior is gone, and my CPU usage is back to normal by the way :slight_smile:

Wodger

Actually, it turns out that’s perfectly fine. You just have to log on first.

I ended up doing significantly more testing and posted a better overview on Reddit.

Will look at your Android issues later if I can.