Transcoding on J5040 in Docker


I recently purchased an Asrock J5040 itx motherboard which uses the Intel Pentium Silver J5040.
Before I had a Raspberry Pi and there were some files the Pi could just not transcode.

Video info for one of these files:
Title 1080p HEVC
Codec HEVC
Profile Main 10
Level 120
Resolution 1920x1080
Aspect ratio 16:9
Interlaced No
Framerate 23.976025
Bitrate 1112 kbps
Pixel format yuv420p10le
Ref frames 1

Happy to find out that my new setup can handle the transcode, BUT only on software transcoding.
I would like to have hardware transcoding of course, since this setup has a lot of encoding / decoding hardware options:

I run Jellyfin with docker, here’s a portion of the docker-compose:
- /dev/dri/renderD128:/dev/dri/renderD128
- /dev/dri/card0:/dev/dri/card0
PUID: 1000
PGID: 1000
TZ: Europe/Amsterdam
UMASK_SET: “022”
- 109
- 44

The groups are for “video” and “render”.
When I try to hardware transcode (I use VAAPI), the sound is going okay but the video is not. I’m not sure how to explain it but I hope this screenshot will:

The video is not fluent, sometimes the screen is black, and then sometimes something like this above shows up.

System information:
OS: Ubuntu server 20.04 64bit
Jellyfin: 10.6.4 (tried the nightly build also, but the same result)

Does anyone have an idea where to search for the problem? My hours long trip on Google has not made me wiser. Thank you!

Good day,

Have you found a solution yet?

I for one have the exact same configuration. J5040 and Ubuntu server 20.04 with Jellyfin in Docker.

HWA with VAAPI went a little better, when I installed an older i965 driver. Unfortunately still not the desired result…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.