Unable To Access NAS Mapped Network Drive (Windows 10)

Hey all,

I am having some struggles getting Jellyfin to see my mapped network drive. In windows the drive is mapped to J, but Jellyfin doesn’t see a J drive. I can access the drive through Windows just fine. I have switched from the service install to the normal one, tried accessing it through the network, and adding my credentials to Windows Credential Manager. I think this is an issue to do with the NAS username and password but if anyone has any ideas let me know. Here is some general info:

NAS: WDMyCloud WDBCTL0060HWT-NESN
Jellyfin Build Number: 10.6.4
OS: Windows 10 Education

Thanks!

I’ve had issues like this - try mapping to \\NAS\Media_Folder rather than J:\Media_Folder (replace NAS with whatever the network name of your device is)

Jellyfin does not seem to like windows mapped shares and using the network share name is better, especially if, like me, you manage if remotely

Hey there, I tried that but it doesn’t seem to work. Says it can’t find path both with the Name and IP of the NAS. I’m guessing it has something to do with the Username and Password on NAS, I have them saved in Windows Credential Manager but it still doesn’t load. :confused:

Permissions on the NAS? you will need guest access authorised

So as far as I can tell I can’t completely disable a username and password in the NAS. I can set the share to public, but the user is still prompted for a username and password.

That’s probably a symptom of the issue - you need to be able to access without a password and username.

What NAS are you running? I think you should be enabling “Guest” access and not just public, depending on the OS they may not be the same thing.

This is a Win10 server, works fine

image

Hi, I have the same problem and I can’t solve it, I have the nas folders as letter-mapped network drives, but I can’t add them to the library. They do not appear in the list of units only C.
When I’m going to add them, he tells me that he can’t find them

Can you tell me what I could be doing wrong?

my installation is windows 10 home 64bits, jellyfin 10.6.4 x64.

Thanks.

As per my solution above, it doesn’t seem to work well from letter mapped drives, try giving it the network share name instead.
Also make sure your NAS has guest access enabled for the media folders

Do you have SMB 1.0 client and server turned on? Look in Control Panel\Programs and Features.
Look for SMB 1.0/CIFS File sharing support. Under that SMB Direct. Turn them on…

Only way I got my win shares to work. May help you out/ May not…